Ask Your Question
0

quest vm no cowsay

asked 2015-08-24 02:03:55 -0500

theplayroom gravatar image

I'm trying to work my way through the quests in the training VM. But on running the --noop command in Manifests and classes I get the following result.

puppet apply --noop cowsayings/tests/cowsay.pp Error: Evaluation Error: The attribute 'ensure' has already been set in this resource body at /etc/puppetlabs/code/environments/production/modules/cowsayings/manifests/cowsay.pp:2:5 on node learning.puppetlabs.vm

Running cowsay shows the following error -bash: cowsay: command not found

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
0

answered 2016-06-30 08:26:06 -0500

hcsg25 gravatar image

Following the instruction, I got the cowsay to work, but fortune doesnt seem to install anything. I went through exactly the same commands and have compares the manifest and definition file.

CORRECTION.....I missed out the include statement d'oh. All works now.

edit flag offensive delete link more
0

answered 2016-01-14 10:44:21 -0500

Any news from Puppet on when the learning VM will be reviewed/updated? I have a whole bunch of dependency errors coming up when running "puppet agent --test" on the final task of the PowerofPuppet quest.

Many Thanks.

edit flag offensive delete link more
0

answered 2015-12-17 15:33:23 -0500

Pretty sure this is just broken right now. Puppet updates borked Learning VM lessons, which haven't been updated yet.

I'm seeing failures and errors on the last question of the "Power of Puppet" section, too. I'm still learning about this, but I think this is due to the fact that the target package (cowsay) isn't in the repository:

[root@learning /etc/puppetlabs/code/environments/production/modules/cowsayings]# puppet module search cowsay Notice: Searching https://forgeapi.puppetlabs.com ... No results found for 'cowsay'.

edit flag offensive delete link more
0

answered 2016-02-22 16:57:33 -0500

milo gravatar image

Facing package installation troouble. Parser or apply doesn't throw error but havt to install the packages with puppet apply -e pr any provider

edit flag offensive delete link more
-1

answered 2015-08-31 07:07:53 -0500

Hello, I am also getting same error, did you get the solution of it?

Can someone please reply on it?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-08-24 02:03:55 -0500

Seen: 2,262 times

Last updated: Jun 30 '16