Ask Your Question
0

razor default puppet agent settings (2015.2)

asked 2015-09-08 05:27:29 -0600

FranzCC gravatar image

updated 2015-09-08 05:29:09 -0600

Hi,
the default settings of the client doesn't comply with our requirements.
We need a shorter runinterval. (runinterval = 5m)
So, when using razor, it loads the agent via http from the puppetmaster.
File:
/opt/puppetlabs/server/apps/razor-server/share/razor-server/brokers/puppet-pe.broker/install.erb
Then install.bash will be executed.
File: /opt/puppetlabs/server/data/packages/public/2015.2.0/install.bash
Reading the install.bash, there seems to be something like a hook function grabbing $@ and sending it to the function custompuppetconfiguration. Of course i can tweak the install.bash file, but why not using hooks like any other linux based software does ?
It would be sufficient to $* from the cmdline args and pass it to the custompuppetconfiguration function.
Right now, again i have to tweak and change an enterprise product.
Any other options would be highly appreciated.

Rgds.
Franz

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-08 05:54:32 -0600

FranzCC gravatar image

This is my "hotfix":
--- install.bash 2015-09-08 12:55:11.961926855 +0200
+++ install.bash.new 2015-09-08 12:54:44.321927183 +0200
@@ -85,6 +85,7 @@
fi

"${PUPPETBINDIR}/puppet" config set server puppetmaster.grazkom.at --section main
+ "${PUPPETBINDIR}/puppet" config set runinterval 300 --section main

if [ "${t_surgery}" = 'yes' ]; then
if [ "x$(uname -s)" = "xDarwin" ]; then

Rgds.
Franz

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-09-08 05:27:29 -0600

Seen: 61 times

Last updated: Sep 08 '15