Ask Your Question
0

forbidden request on API

asked 2015-09-11 09:48:38 -0500

chriscowley gravatar image

updated 2015-09-11 09:54:33 -0500

When I run

/opt/puppetlabs/bin/puppet node find <nodename>

I get the expected wall of JSON and agents work fine too.

However, I would like to set up monitoring. When I run:

curl --cert /etc/puppetlabs/puppet/ssl/certs/<nodename>.pem \
     --key /etc/puppetlabs/puppet/ssl/private_keys/<nodename>.pem \
     --cacert /etc/puppetlabs/puppet/ssl/ca/ca_crt.pem \
     -H 'Accept: pson' \
     https://<puppetmaster>:8140/puppet/v3/status/<nodename>?environment=production

the server returns Error 403: Forbidden

Is there something in auth.conf to add to enable acces to API outside of CLI?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-09-11 09:58:52 -0500

chriscowley gravatar image

It's always a F*ing DNS problem!

edit flag offensive delete link more

Comments

lol. yep dns in itself seems suboptimal :-0

sahumphries gravatar imagesahumphries ( 2015-09-11 10:08:17 -0500 )edit
0

answered 2015-09-11 10:17:48 -0500

Hi,

can you try and telnet puppetmaster 8140 ?

if can connect etc I'd try and open up auth.conf

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-11 09:48:38 -0500

Seen: 351 times

Last updated: Sep 11 '15