Ask Your Question
0

Could not find class concat::setup

asked 2015-09-11 15:22:26 -0500

MsFantastic gravatar image

I've recently build from scratch a new pe Master 3.8.1 (Previously on 3.2) - Upon setting up my first agent I run into a defined class error that I know I haven't set anywhere in ANY of my environments.

Error: Could not retrieve catalog from remote server: "Error 400 on SERVER: Could not find class concat::setup newnode-1 on node newnode-1

Warning: Not using cache on failed catalog

Error: Could not retrieve catalog; skipping run

Am I missing something new in this version that includes this defines this as a required class?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-12 04:40:13 -0500

Hi,

You have to include the concat module in your manifest.

Concat is not included to Puppet out of the box.

Cheers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-11 15:22:26 -0500

Seen: 444 times

Last updated: Sep 12 '15