Ask Your Question
0

I am getting following error with nexus 9k No set of title patterns matched the title "interface Ethernet1/1

asked 2015-09-11 20:02:13 -0500

sanjay gravatar image

updated 2015-09-13 19:02:26 -0500

GregLarkin gravatar image

Folks, I am getting the following error with cisco n9k, It does not complain on the cisco_ospf but the later part the suite.pp is

node 'n9300' {
   cisco_ospf { 'Sample':
   ensure                          => 'present'
   }
   cisco_command_config { 'interface Ethernet1/1 switchport mode trunk': }

Error is

bash-4.2# sudo puppet agent -t
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: No set of title patterns matched the title "interface Ethernet1/1 switchport mode trunk".
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
bash-4.2#

With Debug now

See: http://pastebin.com/1whDtpDm

edit retag flag offensive close merge delete

Comments

Please add the "--debug" option to the puppet agent run and post a link to a pastebin of the output. That may help troubleshoot the issue further. I assume you've already read this documentation? https://forge.puppetlabs.com/puppetlabs/ciscopuppet#type-cisco_command_config

GregLarkin gravatar imageGregLarkin ( 2015-09-12 21:00:07 -0500 )edit

In the future, please create a pastebin of your debug output and post a link to it here instead of posting the debug output inline. It keeps the question page much cleaner and easier to read. I have taken the liberty of doing that and set the pastebin link to "unlisted".

GregLarkin gravatar imageGregLarkin ( 2015-09-13 19:00:39 -0500 )edit

You will need to invoke Puppet as "sudo puppet agent -t --debug". The "-t" option needs to be there as well. Please do that, create a pastebin of the output and add the pastebin link to your original question.

GregLarkin gravatar imageGregLarkin ( 2015-09-13 19:04:39 -0500 )edit

Please find the details at http://pastebin.com/sk7Su9d8 with -t and --debug

sanjay gravatar imagesanjay ( 2015-09-14 12:54:32 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-09-16 18:16:08 -0500

sanjay gravatar image

updated 2015-09-16 18:23:27 -0500

JohnsonEarls gravatar image

Correct Syntax for n9300 in the manifest file site.pp is given below, and it works with this You need to specify the command in command config.

cisco_command_config { "interface_Ethernet_switchport_mode_trunk":
   command     => " interface Ethernet1/3 
switchport mode trunk "
   }

=========You can check on n9300 below====

n9300# sh runn int e1/3

!Command: show running-config interface Ethernet1/3
!Time: Tue Sep 15 18:27:18 2015

version 7.0(3)I2(1)

interface Ethernet1/3
  switchport mode trunk
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-11 20:02:13 -0500

Seen: 200 times

Last updated: Sep 16 '15