Ask Your Question
0

Cannot connect agent to puppet master

asked 2015-09-16 04:11:52 -0500

scottsweb gravatar image

image description

Hello, when I run puppet on my windows 8 agent it returns me with the following error.

I am able to ping both puppet master and agent from each machine

The conf file is configured to point to the right puppet master.

When I run puppet cert list it is empty and running puppet cert sign --all says there are no waiting certificate requests to sign

Any ideas on how to fix this problem much appreciated.

Thanks, scottsweb

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-16 11:26:27 -0500

GregLarkin gravatar image

Please check the following:

  • Does the hostname "puppet" resolve to an IP address?
  • Can you ping hostname "puppet" successfully? (I assume you've successfully pinged the Puppet master FQDN)
  • Does your Puppet master have a firewall running (iptables or other) that prevents connections to port 8140?
  • Is the Puppet master running, and is it listening on port 8140?
  • Does your Windows 8 machine have a firewall enabled that prevents outbound connections to port 8140 on your Puppet master?

I hope one of these tests will lead you to a solution, but if not, please post back here with any relevant debug/logging information from the above commands.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-16 04:11:52 -0500

Seen: 603 times

Last updated: Sep 16 '15