Ask Your Question

Serving File from custom mount point PE 2015.2 BUG

asked 2015-09-16 05:30:46 -0600

FranzCC gravatar image

it seems, that an old BUG hasn't been fixed in 2015.2.
Serving a file from a custom location works but :
It works one time, when changing auth.conf
The next run i get an error 400.
Of course, the filepermissions are right, and as i told, it works for one time only ;-)

fileserver.conf snip:
path /var/cpepackages
allow *

path /var/cpeconfs
allow *

path ~ ^/file_(metadata|content)s?/cpepackages/.*
method find, search
auth yes
allow *

path ~ ^/file_(metadata|content)s?/cpeconfs/.*
method find, search
auth yes
allow *

Pastebin puppetserver-log with error 400:

Pastebin puppetserver-log with code 200 (OK)

Nevertheless, i will file a bug report and create an issue soon.

This is a showstopper par excellence !



edit retag flag offensive close merge delete


Please post a directory listing showing the ownership and permissions of the /var/cpepackages and /var/cpeconf directories. Also, does restarting the Puppet server give you one more successful agent run and then continued failures after that?

GregLarkin gravatar imageGregLarkin ( 2015-09-16 11:32:12 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-09-17 01:03:17 -0600

FranzCC gravatar image

Hi Greg,
restarting the pe-puppetserver worked.
Perhaps this should be outlined in the docs:



edit flag offensive delete link more


Does everything continue to work fine after that restart?

GregLarkin gravatar imageGregLarkin ( 2015-09-18 15:38:13 -0600 )edit

Hi Greg, yes, it's working. I tested it on some nodes. Rgds. Franz

FranzCC gravatar imageFranzCC ( 2015-09-21 02:40:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-09-16 05:30:46 -0600

Seen: 386 times

Last updated: Sep 17 '15