Ask Your Question
0

Puppet master refusing connections

asked 2015-09-22 04:19:36 -0500

scottsweb gravatar image

Hello,

I am trying to connect my centOS agent (hostname: pagent) to its puppetmaster (hostname: pmaster)

The host files and config files have been set up to look at the right machines

When I run telnet pmaster it states that the connection is refused:

Trying: 192.168.47.136 telnet: connect to address 192.168.47.136: Connection Refused

How do I fix this? I am pretty new to all this, any help appreciated, thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-22 04:45:09 -0500

rajeevsharma gravatar image

Hi Scottsweb,

Puppet master listens on port 8140 by default and remote agent connects to that port. Try, telnet 192.168.47.136 8140

If this command succeed you are good to go if not please check your firewall settings. Turning off the firewall could do the trick or you can enable required ports into your iptable rules.

thanks.

edit flag offensive delete link more

Comments

Hello, thanks for your response, I have tried this and it is still coming back as connection refused. This is with iptables off? Is there anything else I need to turn off? thanks again

scottsweb gravatar imagescottsweb ( 2015-09-22 04:56:45 -0500 )edit

Turning off the iptables would suffice. Please check 8140 port is in listening mode. [root@puppetmaster ~]# netstat -nap | grep 8140 tcp 0 0 0.0.0.0:8140 0.0.0.0:* LISTEN 1881/ruby [root@puppetmaster ~]# If not, do a restart.

rajeevsharma gravatar imagerajeevsharma ( 2015-09-22 05:05:34 -0500 )edit

if I run netstat -nap | grep 8140 it doesn't return anything?

scottsweb gravatar imagescottsweb ( 2015-09-22 05:16:41 -0500 )edit

Try restarting puppet master "sudo service pe-httpd restart" or you can check logs /var/log/pe-httpd/ for errors.

rajeevsharma gravatar imagerajeevsharma ( 2015-09-22 05:22:33 -0500 )edit

httpd unrecognized service? This was once working, not sure what ive managed to do to break it :(

scottsweb gravatar imagescottsweb ( 2015-09-22 05:29:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-09-22 04:19:36 -0500

Seen: 1,700 times

Last updated: Sep 22 '15