Ask Your Question
0

puppet file server and custom mount issue

asked 2015-10-01 09:28:41 -0500

Narahari gravatar image

his is more of a question for the custom mount point which is on the same lines as above.

I have the following on the puppet master

[service_misc] 
path /opt/service/scripts/misc
allow *

On the puppet agent I run the command

sudo puppet apply--write-catalog-summary -e "file {'/home/virtual/test.sh': ensure => file, recurse => remote, owner  => 'root', group => 'root', source => 'puppet:///service_misc/test.sh', mode => 755, replace => 'yes',}"

I see the following error

Error:
/Stage[main]/Main/File[/home/virtual/test.sh]:
Could not evaluate: Could not retrieve information from environment
production source(s) puppet:///service_misc/test.sh

Not sure what I am doing wrong.

-Narahari

edit retag flag offensive close merge delete

Comments

I'm not sure if it's needed or not, but did you restart the Puppet master process after modifying the fileserver.conf file?

GregLarkin gravatar imageGregLarkin ( 2015-10-01 11:27:16 -0500 )edit

I will try to restart the pup master process but if the is a requirement it creates a huge bottle neck. If there are deployments going on in other machines but if I need to get a mount to serve files to bunch of servers using mco-fileserver combination this restart approach is a huge blockage.

Narahari gravatar imageNarahari ( 2015-10-01 11:57:02 -0500 )edit

I'm not 100% sure that it's required, so let me know if that fixes the problem or not. If it still fails, there may be something else going on.

GregLarkin gravatar imageGregLarkin ( 2015-10-01 12:26:02 -0500 )edit

I tried the restart of the process on the puppet master and the puppet master itself but no luck. I am still seeing the same error, so something else is happening.. If anyone has seen this issue please help.

Narahari gravatar imageNarahari ( 2015-10-01 14:05:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-01 14:08:04 -0500

Narahari gravatar image

Moving from comments to answers.

I'm not sure if it's needed or not, but did you restart the Puppet master process after modifying the fileserver.conf file?

GregLarkin gravatar imageGregLarkin (2 hours ago)

I will try to restart the pup master process but if the is a requirement it creates a huge bottle neck. If there are deployments going on in other machines but if I need to get a mount to serve files to bunch of servers using mco-fileserver combination this restart approach is a huge blockage.

Narahari gravatar imageNarahari (2 hours ago)edit

I'm not 100% sure that it's required, so let me know if that fixes the problem or not. If it still fails, there may be something else going on.

GregLarkin gravatar imageGregLarkin (1 hour ago)

I tried the restart of the process on the puppet master and the puppet master itself but no luck. I am still seeing the same error, so something else is happening.. If anyone has seen this issue please help.

Narahari gravatar imageNarahari (just now)edit

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-01 09:28:41 -0500

Seen: 172 times

Last updated: Oct 01 '15