puppet device assuming top level /home/user/.puppet

asked 2013-07-05 03:25:27 -0500

BaltoStar gravatar image

Ubuntu 12.04.2 LTS server with puppet master and agent serving as f5_proxy

I have located all modules, manifests, and config files under top level /etc/puppet

/etc/puppet/modules
/etc/puppet/manifests
/etc/puppet/device

However on executing

$ puppet device

puppet outputs a slew of resource-not-found errors apparently because puppet is searching under top level /home/{myaccount}/.puppet

How could this happen ? Could it be that puppet was installed multiple times on this server in multiple contexts ?

How can I reconfigure Puppet to assume top-level dir = /etc/puppet ?

Thanks.

edit retag flag offensive close merge delete

Comments

2

If you "su" (or sudo) to the root user, puppet will operate on the /etc/puppet directory instead.

GregLarkin gravatar imageGregLarkin ( 2013-07-05 14:18:45 -0500 )edit

Thanks Greg. I ran `sudo puppet device` and this led to another question : `https://ask.puppetlabs.com/question/1943/f5-gem-install-on-device-proxy-agent/`. Could you please take a look ?

BaltoStar gravatar imageBaltoStar ( 2013-07-05 19:31:26 -0500 )edit

I just got back from vacation and am catching up now. Did you solve this problem? The question you referenced above seems to be deleted now.

GregLarkin gravatar imageGregLarkin ( 2013-07-15 20:31:33 -0500 )edit

Hi Greg. I made some limited progress with F5 but am still encountering serious problems. Could you please take a look ? https://ask.puppetlabs.com/question/2026/puppet-f5-device-config-partition-doesnt-exist/

BaltoStar gravatar imageBaltoStar ( 2013-07-16 09:21:12 -0500 )edit