Ask Your Question
0

PE installation appears to hang on Ubuntu

asked 2015-10-07 12:28:54 -0500

jkerr gravatar image

Running the installer trial version on Ubuntu 14.04 for a monolithic installation and the installation seems to hang at the "Installing your Deployment" point within "Install puppet enterprise on <your system="">". The task spins and spins and never completes. The log displays "* HTTP_PROXY= http_proxy= HTTPS_PROXY= https_proxy= /opt/puppetlabs/puppet/bin/curl --tlsv1 -s --cacert /etc/puppetlabs/puppet/ssl/certs/ca.pem --key /opt/puppetlabs/server/data/console-services/certs/puppet..private_key.pem --cert /opt/puppetlabs/server/data/console-services/certs/puppet..cert.pem https://puppet.:4433/classi... | grep -q last_update.[[:digit:]]".

I can reach the login screen but the admin credentials are rejected. I have left the install for hours and also uninstalled and reinstalled several times without success as the installer appears stuck in the same spot.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-07 16:21:47 -0500

jkerr gravatar image

Opening up port 4433 in the firewall allowed the curl command to complete and the install to progress.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-07 12:28:54 -0500

Seen: 103 times

Last updated: Oct 07 '15