Ask Your Question
1

Puppet Master and Phusion Passenger Fails

asked 2013-07-07 18:05:24 -0600

louis gravatar image

updated 2013-07-07 18:09:28 -0600

C:\fakepath\full.log.jpegI have the following error trying to set up puppet master and phusion passenger module for Apache.

Environment Details:

  • Puppet 3.2.2
  • Centos 6.4 (64bits)
  • Vagrant 1.2.2

     in 'void Passenger::ApplicationPool2::SmartSpawner::handleErrorResponse(Passenger::ApplicationPool2::SmartSpawner::StartupDetails&)' (SmartSpawner.h:455)
     in 'std::string Passenger::ApplicationPool2::SmartSpawner::negotiatePreloaderStartup(Passenger::ApplicationPool2::SmartSpawner::StartupDetails&)' (SmartSpawner.h:558)
     in 'void Passenger::ApplicationPool2::SmartSpawner::startPreloader()' (SmartSpawner.h:206)
     in 'virtual Passenger::ApplicationPool2::ProcessPtr Passenger::ApplicationPool2::SmartSpawner::spawn(const Passenger::ApplicationPool2::Options&)' (SmartSpawner.h:744)
     in 'void Passenger::ApplicationPool2::Group::spawnThreadRealMain(const Passenger::ApplicationPool2::SpawnerPtr&, const Passenger ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-07-08 13:23:08 -0600

louis gravatar image

updated 2013-07-08 14:47:32 -0600

louis gravatar image

I fixed the issue by starting the puppet master daemon. But thank you for the observations about the apache configuration since I am not a passenger conf savvy person.

LoadModule passenger_module /usr/lib/ruby/gems/1.8/gems/passenger-4.0.7/buildout/apache2/mod_passenger.so
PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-4.0.7
PassengerDefaultRuby /usr/bin/ruby
PassengerLogLevel 3 

# you probably want to tune these settings
PassengerHighPerformance on
PassengerMaxPoolSize 12
PassengerStatThrottleRate 120
PassengerMaxRequests 1000
#RackAutoDetect Off
#RailsAutoDetect Off

Listen 8140

<VirtualHost *:8140>
        SSLEngine on
        SSLProtocol -ALL +SSLv3 +TLSv1
        SSLCipherSuite ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:-SSLv2 ...
(more)
edit flag offensive delete link more

Comments

Was it that the ssl certs and what not didn't exist without the puppet master running at least once?

ramindk gravatar imageramindk ( 2013-07-08 13:43:44 -0600 )edit

Actually i did run it once, saved the ssl folder and then just copied using a file resource. In my opinion, there should be a command line to generate the ...(more)

louis gravatar imagelouis ( 2013-07-08 14:43:31 -0600 )edit

2 things I'd change in your vhost config. Set PassengerMinInstances 1 or Passenger will shutdown any app not taking traffic every 300s. The second is add a line like ...(more)

ramindk gravatar imageramindk ( 2013-07-08 15:32:11 -0600 )edit

Interesting. Thank you for this one.

louis gravatar imagelouis ( 2013-07-08 19:33:39 -0600 )edit
2

answered 2013-07-08 12:39:30 -0600

ramindk gravatar image

Looks like a bad path, but there are several things in your setup I do not like. In any case make sure DocumentRoot and Directory are the same.

    DocumentRoot /etc/puppet/rack/public/
    RackBaseURI /
    <Directory /etc/puppet/rack/public/
            Options None
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

Now for the things I don't like. PassengerEnable is on by default so no need to set it. Also it only makes sense when you're running an app within a vhost that's doing something else.

PassengerPoolIdleTime 15 is a bit silly when you're already setting a ... (more)

edit flag offensive delete link more

Comments

Thanks for this answer although I forgot to start the puppet master daemon and that was causing this issue. Running a clean vagrant install just to verify

louis gravatar imagelouis ( 2013-07-08 13:24:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-07 18:05:24 -0600

Seen: 2,410 times

Last updated: Jul 08 '13