Ask Your Question
0

Unable to install Puppet server due to dependency error

asked 2015-10-13 22:55:03 -0500

gopakumar_mg gravatar image

updated 2015-10-19 20:33:02 -0500

GregLarkin gravatar image

Hi,

When we try to install puppet-server, we received below error message. We already have ruby(ver. 1.9.3) installed in the server but getting dependency error. It would be helpful if anyone can give the solution for this. Thank you.

[root@myserver ~]# yum install puppet-server
Loaded plugins: security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package puppet-server.noarch 0:3.8.3-1.el6 will be installed
--> Processing Dependency: puppet = 3.8.3-1.el6 for package: puppet-server-3.8.3-1.el6.noarch
--> Running transaction check
---> Package puppet.noarch 0:3.8.3-1.el6 will be installed
--> Processing Dependency: facter >= 1:1.7.0 for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: ruby >= 1.8.7 for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: ruby >= 1.8 for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: rubygem-json for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-3.8.3-1.el6.noarch
--> Running transaction check
---> Package facter.x86_64 1:2.4.4-1.el6 will be installed
--> Processing Dependency: ruby >= 1.8.7 for package: 1:facter-2.4.4-1.el6.x86_64
--> Processing Dependency: /usr/bin/ruby for package: 1:facter-2.4.4-1.el6.x86_64
---> Package hiera.noarch 0:1.3.4-1.el6 will be installed
--> Processing Dependency: ruby >= 1.8.5 for package: hiera-1.3.4-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: hiera-1.3.4-1.el6.noarch
---> Package puppet.noarch 0:3.8.3-1.el6 will be installed
--> Processing Dependency: ruby >= 1.8.7 for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: ruby >= 1.8 for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-3.8.3-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.8.3-1.el6.noarch
---> Package ruby-augeas.x86_64 0:0.4.1-3.el6 will be installed
--> Processing Dependency: ruby(abi) = 1.8 for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: augeas-libs >= 0.8.0 for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libruby.so.1.8()(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.4.1-3.el6.x86_64
---> Package ruby-shadow.x86_64 1:2.2.0-2.el6 will be installed
--> Processing Dependency: ruby for package: 1 ...
(more)
edit retag flag offensive close merge delete

Comments

whats your OS - also where are you getting puppet-server from - puppetlabs or your OS provider?

sahumphries gravatar imagesahumphries ( 2015-10-14 04:49:54 -0500 )edit

OS - Redhat 6.4 and we are getting puppet-server from puppetlabs.

gopakumar_mg gravatar imagegopakumar_mg ( 2015-10-14 07:45:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-14 10:43:22 -0500

Chris gravatar image

Very hard to read you output - next time wrap in preformated tag enter code here. Anyway my best guess is that you already have ruby install or a ruby component that is a version conflicting with the puppet install.

Check to see if you have ruby installed and what version it is - ruby --version

Looks like the version of puppet you are install ing (3.8) is looking to install Requires: ruby >= 1.8.7. If that is the issue then try uninstalling ruby and then again installing puppet-server again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-13 22:55:03 -0500

Seen: 1,233 times

Last updated: Oct 19 '15