About | FAQ | Help
Ask Your Question

Errors while installing latest open source version of puppetserver

asked 2015-10-20 11:00:56 -0500

eugene.tsypkin gravatar image

I've tried to install the open source version of puppetserver on ubuntu 14.04 based on this document https://docs.puppetlabs.com/puppetser...frompackages.html. For that I did

wget https://apt.puppetlabs.com/puppetlabs-release-trusty.deb
sudo dpkg -i puppetlabs-release-trusty.deb
sudo apt-get update
sudo apt-get install puppetserver

I didn't face any errors while executing, but when I tried to start service by executing

sudo service puppetserver start

It failed with the error in the logs (/var/log/puppetlabs/puppetserver/puppetserver.log)

(RuntimeError) Got 1 failure(s) while initializing: File[/etc/puppetlabs/puppet/ssl]: change from absent to directory failed: Could not set 'directory' on ensure: Permission denied - /etc/puppetlabs/puppet/ssl

What is also weird that when I tried to get the puppet agent version

sudo /opt/puppetlabs/bin/puppet --version

I've got another error

libfacter was not found. Please make sure it was installed to the expected location.

Could anybody please point me what did I miss?

Thank you in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-10-21 15:27:56 -0500

eugene.tsypkin gravatar image

At list I've found out what was the problem with the puppet agent.

the deal was that in the /etc/ssh/sshd_config I had AcceptEnv LANG LC_* that is stends for propagation of my local environment vars to the guest machine when I connect via ssh.

As far as facter reads environment variable, it blows up when it reads something that it doesn't know here is the ticket about that https://tickets.puppetlabs.com/browse...

edit flag offensive delete link more


Thanks a lot! Another quick fix is: Run `export` to find out which locales you are enforcing (for example `de_DE.UTF-8`). Then run `sudo locale-gen de_DE.UTF-8`. And all of a sudden, Puppet will run like magic.

Arney gravatar imageArney ( 2016-02-02 12:57:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-10-20 11:00:56 -0500

Seen: 953 times

Last updated: Oct 21 '15