Ask Your Question
0

deploy bacula enterprise

asked 2015-10-23 16:05:31 -0600

Salim gravatar image

Hello,

I am trying to deploy bacula enterprise using local rpm. I made a module but i have an issue to install the dependencies. Is there a way i can make Puppet looking for dependencies using yum.

class bacula {

package{ ['bacula-enterprise-client','bacula-enterprise-libs']:

ensure => installed, provider => rpm, source => ['/nfs/releases/rpm/bacula-enterprise-client-8.0.3-1.el6.x8664.rpm', 'bacula-enterprise-libs-8.0.3-1.el6.x8664.rpm'] }

service { 'bacula-fd': ensure => running, enable => true, require => Package['bacula-enterprise-client','bacula-enterprise-libs'], }

}

Error i am getting:

Error: Execution of '/bin/rpm -i /nfs/releases/rpm/bacula-enterprise-client-8.0.3-1.el6.x8664.rpm bacula-enterprise-libs-8.0.3-1.el6.x8664.rpm' returned 2: warning: /nfs/releases/rpm/bacula-enterprise-client-8.0.3-1.el6.x8664.rpm: Header V4 DSA signature: NOKEY, key ID a361392a error: Failed dependencies: libcrypto.so.10()(64bit) is needed by bacula-enterprise-client-8.0.3-1.el6.x8664 libreadline.so.6()(64bit) is needed by bacula-enterprise-client-8.0.3-1.el6.x8664 libssl.so.10()(64bit) is needed by bacula-enterprise-client-8.0.3-1.el6.x8664 libtinfo.so.5()(64bit) is needed by bacula-enterprise-client-8.0.3-1.el6.x8664 python >= 2.6 is needed by bacula-enterprise-client-8.0.3-1.el6.x8664 rpmlib(FileDigests) <= 4.6.0-1 is needed by bacula-enterprise-client-8.0.3-1.el6.x8664 rpmlib(PayloadIsXz) <= 5.2-1 is needed by bacula-enterprise-client-8.0.3-1.el6.x8664 libcrypto.so.10()(64bit) is needed by bacula-enterprise-libs-8.0.3-1.el6.x8664 libcrypto.so.10(libcrypto.so.10)(64bit) is needed by bacula-enterprise-libs-8.0.3-1.el6.x8664 libssl.so.10()(64bit) is needed by bacula-enterprise-libs-8.0.3-1.el6.x8664 libssl.so.10(libssl.so.10)(64bit) is needed by bacula-enterprise-libs-8.0.3-1.el6.x8664 rpmlib(FileDigests) <= 4.6.0-1 is needed by bacula-enterprise-libs-8.0.3-1.el6.x8664 rpmlib(PayloadIsXz) <= 5.2-1 is needed by bacula-enterprise-libs-8.0.3-1.el6.x8664

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-10-26 19:21:20 -0600

GregLarkin gravatar image

The only thing Puppet does is run the underlying rpm or yum command that you would normally do. If you use the rpm provider, you will have to follow the complete chain of dependent packages and make sure they are are installed in the proper order. This is no different than if you did it manually yourself.

If at all possible, use the yum provider and make an internal yum repository, mirroring the bits you need. Then you can install the top-level package and all of the dependencies will be taken care of automatically.

edit flag offensive delete link more
0

answered 2015-11-03 04:34:23 -0600

Salim gravatar image

Thank you, it helped. I have setup a local yumrepo and yum was able to resolve all dependencies

edit flag offensive delete link more

Comments

Excellent, glad to hear it.

GregLarkin gravatar imageGregLarkin ( 2015-11-03 10:39:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-23 16:05:31 -0600

Seen: 347 times

Last updated: Nov 03 '15