Ask Your Question
0

foreman fast question

asked 2015-10-24 16:37:16 -0600

tagomasa gravatar image

updated 2015-10-24 16:39:39 -0600

I have made all correct: create puppet master,then environment(called serverftp) add of course hosts to environment,create group host,with assigned class(module vsftpd). I make all changes correct with foreman gui(setting for example passive ports) The question is,after make the changes and did

puppet agent --test

On foreman host,the other host don't update automatically? If i did for every host

puppet agent --test

On host i see this warning

Warning: Local environment: "production" doesn't match server specified node environment "serverftp", switching agent to "serverftp".

But foreman report they're on serverftp Then they update the vsftpd.conf

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-10-26 03:10:38 -0600

Cristian Falcas gravatar image

The warning is normal, as the default environment for puppet is production. To get rid of the warning, either update manually the puppet.conf file with "environment=serverftp" on the [agent] section or use the puppet module to configure the file for you.

The command "puppet agent -t" is running only on the current host, so you have to execute the command on each host, or execute it from a cron job on each host. You could also use mcollective to execute puppet runs, but this may be a little to advance for you at this moment.

edit flag offensive delete link more

Comments

Thanks for answer environement,I found a better solution for running puppet as service on client puppet resource service puppet ensure=running enable=true and systemctl enable puppet

tagomasa gravatar imagetagomasa ( 2015-10-31 19:32:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-24 16:37:16 -0600

Seen: 404 times

Last updated: Oct 26 '15