Ask Your Question

Error "missing vitual host" while installing apache

asked 2015-10-26 12:19:29 -0600

var kanduku gravatar image

updated 2015-10-26 19:40:06 -0600

Im about to install apache on my ubuntu 14 node but im getting the following error. The error details are provided in the following link. link text


edit retag flag offensive close merge delete


You should post a link to a pastebin of the contents of the conf file in question. Also, please delete the image and repost a link to a pastebin of the output of the puppet agent command. It's so much easier to read and help you troubleshoot that way.

GregLarkin gravatar imageGregLarkin ( 2015-10-26 19:16:00 -0600 )edit

There's an error in /etc/apache2/sites-enabled/, so we need to see the contents of that file and any related Puppet code that might have created it.

GregLarkin gravatar imageGregLarkin ( 2015-10-26 19:44:09 -0600 )edit

init .pp file params.pp file vhost.pp these three files are used to produce it.

var kanduku gravatar imagevar kanduku ( 2015-10-26 19:55:33 -0600 )edit

and here is my vhost template file

var kanduku gravatar imagevar kanduku ( 2015-10-26 19:59:32 -0600 )edit

here is the file that is generated .My vhost config file on node

var kanduku gravatar imagevar kanduku ( 2015-10-26 20:02:24 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-10-26 20:45:55 -0600

GregLarkin gravatar image

In order to fix the error, you need to delete the space character between the ":" and your Ruby variable evaluation in your Apache config file template. That causes the Apache config file reader to generate the error you are observing. The following line:

<VirtualHost *: <%= @port -%>>

changes to:

<VirtualHost *:<%= @port -%>>

That should do it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-10-26 12:19:29 -0600

Seen: 52 times

Last updated: Oct 26 '15