Ask Your Question
2

yum install puppet-server installs the latest version of 3.* , Is there some way i can install the version 2.7.21 on Fedora 19 using yum?

asked 2013-07-12 06:21:03 -0600

Akal gravatar image

I tried to compile with the source code 2.7.21 but somehow there were missing files like ''puppet.conf'' was missing.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-07-15 14:44:49 -0600

lavaman gravatar image

If the rpms for that version are available in your yum repos, you can do the following:

package {'puppet': ensure => '2.7.21', }

the ensure parameter for package will take a version as long as your provider will handle that (yum and apt definitely do).

edit flag offensive delete link more
0

answered 2013-07-17 01:47:49 -0600

Akal gravatar image

Had too much trouble trying to install 2.7.21 over fedora. Finally using the latest puppet version.

edit flag offensive delete link more
0

answered 2013-07-16 16:56:22 -0600

ramindk gravatar image

The answer is no, but with some qualifications. Fedora 19 ships with Ruby 2.0 and Puppet 2.7 won't work with it or at least won't work well. In order to use Puppet 2.7 on Fedora 19. you will need to build Ruby 1.8.7 packages and then install Puppet. You can either build Puppet RPMs which should be fairly simple using the Puppetlabs src RPMs as a base or gem install and then add all the extra files normally found in the RPM to the system.

In my mind it's far simpler to ... (more)

edit flag offensive delete link more

Comments

Yes that's what i finally did.

Akal gravatar imageAkal ( 2013-07-17 01:48:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-12 06:21:03 -0600

Seen: 223 times

Last updated: Jul 17 '13