Ask Your Question
0

disable mcollective?

asked 2015-10-28 04:13:28 -0500

dogfish182 gravatar image

updated 2015-10-30 08:44:26 -0500

Hello all,

I'm just starting with PE 2015.2 and I have an all in one puppet master managing 8 nodes. It's simply managing ntp for these nodes at present, but a developing elasticsearch problems alerted me to the fact that mcollective is doing something horrible to my nodes. Basically it's using up all the memory, the box starts swapping like crazy and then everything crashes.

i want to stop mcollective at the moment while I assess what is going on, however this doesn't seem possible. a basic install of PE 2015.2 seems to start mcollective and it's not possible to stop from the node itself. My questions are these,

  1. do I NEED mcollective (until I've got a chance to really troubleshoot the source of the issue) being that I don't need live management (or whatever it's called now in PE 2015.2).
  2. How do I turn it off?

nodes are all ubuntu 14.04 LTS as is the puppet master.

EDIT:

I've found in the logs the issue. this is after fresh install of a puppet server 2015.2 and nodes were added by running the agent curl command from 'sign certificates'. Therefore total default install produces this result.

I, [2015-10-30T11:23:32.429563 #2555]  INFO -- : mcollectived:64:in `<main>' The Marionette Collective 2.8.6 started logging at info level
I, [2015-10-30T11:23:32.432021 #2562]  INFO -- : activemq.rb:211:in `initialize' ActiveMQ connector initialized.  Using stomp-gem 1.3.3
I, [2015-10-30T11:23:32.434610 #2562]  INFO -- : activemq.rb:139:in `on_ssl_connecting' Establishing SSL session with stomp+ssl://mcollective@server.blah.com:61613
I, [2015-10-30T11:23:32.536952 #2562]  INFO -- : activemq.rb:144:in `on_ssl_connected' SSL session established with stomp+ssl://mcollective@server.blah.com:61613
I, [2015-10-30T11:23:32.539287 #2562]  INFO -- : activemq.rb:119:in `on_connected' Connected to stomp+ssl://mcollective@server.blah.com:61613
E, [2015-10-30T11:23:32.875704 #2562] ERROR -- : agents.rb:71:in `rescue in loadagent' Loading agent puppet failed: Could not create instance of plugin MCollective::Agent::Puppet: Cannot manage Puppet version 4
E, [2015-10-30T11:23:32.880571 #2562] ERROR -- : agents.rb:71:in `rescue in loadagent' Loading agent puppet failed: Could not create instance of plugin MCollective::Agent::Puppet: Cannot manage Puppet version 4
I, [2015-10-30T13:53:22.357048 #1173]  INFO -- : runner.rb:104:in `rescue in block in main_loop' Exiting after signal: SIGTERM
I, [2015-10-30T13:53:22.357075 #2423]  INFO -- : runner.rb:104:in `rescue in block in main_loop' Exiting after signal: SIGTERM
I, [2015-10-30T13:53:22.357513 #2006]  INFO -- : runner.rb:104:in `rescue in block in main_loop' Exiting after signal: SIGTERM
I, [2015-10-30T13:53:22.358893 #2145]  INFO -- : runner.rb:104:in `rescue in block in main_loop' Exiting after signal: SIGTERM
I, [2015-10-30T13:53:22.359253 #2284]  INFO -- : runner.rb:104:in `rescue in block in main_loop' Exiting after signal: SIGTERM
I, [2015-10-30T13:53:22.360190 #2562]  INFO -- : runner.rb:104:in `rescue in block in main_loop' Exiting ...
(more)
edit retag flag offensive close merge delete

Comments

this is an example of what mcollective is doing to my server. http://i.imgur.com/84eiUev.png

dogfish182 gravatar imagedogfish182 ( 2015-10-30 03:49:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-30 06:47:30 -0500

to do this globally:

edit /etc/puppetlabs/puppet-dashboard/settings.yml on the master change disable_live_management = true.

Restart pe-httpd

On the console,make the Default group  the "no mcollective" group. If the "mcollective" group is present in the default group remove it.

after each client runs puppet MCollective should be disabled.
another way is for each client:
puppet resource service pe-mcollective ensure=stopped enable=false

Cheers

Stuart

edit flag offensive delete link more

Comments

I've done this and now my machines stop landing as status 'changed' in the Puppet enterprise interface and it stops the multi restarts of mcollective. However, I appear to be experiencing this issue. https://tickets.puppetlabs.com/browse/PA-7 I'm not able to control this mcollective service.

dogfish182 gravatar imagedogfish182 ( 2015-11-02 03:21:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-28 04:13:28 -0500

Seen: 417 times

Last updated: Oct 30 '15