Ask Your Question
0

Trying to install Vim Package through site.pp

asked 2015-10-28 10:22:41 -0500

Coops20 gravatar image

updated 2015-10-28 10:26:36 -0500

GregLarkin gravatar image

Hi, I am following the pro puppet book - second edition, to learn puppet, I'm currently attempted to install 'Vim' by adding a note definition to the site.pp, the error message I am receiving is as follows ;

Warning: Setting templatedir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations
  (at /usr/lib/ruby/vendor_ruby/puppet/settings.rb:1139:in `issue_deprecation_warning')
Notice: Using less secure serialization of reports and query parameters for compatibility
Notice: with older puppet master. To remove this notice, please upgrade your master(s)
Notice: to Puppet 3.3 or newer.
Notice: See http://links.puppetlabs.com/deprecate_yaml_on_network for more information.
Info: Retrieving pluginfacts
Error: /File[/var/lib/puppet/facts.d]: Failed to generate additional resources using 'eval_generate': Error 400 on SERVER: Not authorized to call search on /file_metadata/pluginfacts with {:links=>"manage", :checksum_type=>"md5", :ignore=>[".svn", "CVS", ".git"], :recurse=>true}
Error: /File[/var/lib/puppet/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet://puppet/pluginfacts: Error 400 on SERVER: Not authorized to call find on /file_metadata/pluginfacts with {:links=>"manage", :source_permissions=>"use"}
Info: Retrieving plugin
Error: /File[/var/lib/puppet/lib]: Could not evaluate: Could not retrieve information from environment production source(s) puppet://puppet/plugins
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find default node or by name with 'puppet-agent-john.openstacklocal, puppet-agent-john' on node puppet-agent-john.openstacklocal
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

Any help on this would be greatly appreciated, pro puppet - second edition - Apress - Spencer Krum - page 25 (this is the book and page number for the task I am trying to complete)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-10-30 12:50:06 -0500

JohnsonEarls gravatar image

updated 2015-10-30 12:52:37 -0500

Based on the Error 400 on SERVER: Not authorized to call search on /file_metadata/pluginfacts type errors, it looks like you might have an invalid auth.conf file in your puppet configuration. I can't tell which version of puppet you're using (other than it's pre-3.3 based on some of the other notices).

Try downloading the /etc/puppet/auth.conf file from https://raw.githubusercontent.com/puppetlabs/puppet/3.2.4/conf/auth.conf . (change the link to the appropriate puppet version).

edit flag offensive delete link more
0

answered 2015-10-30 06:38:04 -0500

Hi, have you signed the cert for this node? the error "Error 400 on SERVER: Could not find default node or by name with 'puppet-agent-john.openstacklocal, puppet-agent-john' on node puppet-agent-john.openstacklocal" makes me think maybe not.

on puppet master try:

puppet cert list - then run puppet cert sign ...nameofcert...

your nodes request for a cert should be there - if not we'll need to dig deeper.

having:

node 'puppet-agent-john.openstacklocal' {
      package { 'vim':
          ensure => present,
      }
 }

in site.pp as per the book should be fine.. i suspect its just cert not signed.

also what version of puppet do you have - may be worth upgrading to latest if you're learning.

cheers Stuart

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-28 10:22:41 -0500

Seen: 412 times

Last updated: Oct 30 '15