Ask Your Question
0

PuppetDB Jetty.ini host = 127.0.0.1

asked 2015-10-29 05:46:45 -0500

olisun gravatar image

Hi,

We are current using PE 3.7.2 and I am trying to get the host entry in the jetty.ini changed to "0.0.0.0".

I tried changing through the params.pp file but the changes keep reverting. And when I change it through the console and it has no effect.

The same change if I try it in PE 3.8.x it works fine.

Is this a bug in PE 3.7.2?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-12 01:29:30 -0500

Cristian Falcas gravatar image

The default are best practice: open to outside world only ssl, keep unencrypted traffic to localhost only.

But, if you want to change it, declare the class like so:

  class { 'puppetdb':
    listen_address       => '0.0.0.0',
  }
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-29 04:52:07 -0500

Seen: 205 times

Last updated: Nov 12 '15