Ask Your Question
0

Is it safe to follow the puppet-enterprise-installer -n steps manually?

asked 2013-07-12 23:19:10 -0600

BillWeiss gravatar image

updated 2013-07-16 11:30:26 -0600

For a really dumb reason, I have a box that PE won't install on. I'm still in the 10 free node license so I can't just ask support :)

Anyway, I ran ./puppet-enterprise-installer -n -l ~/asdf. If I can get those steps to run, that's the same as doing the install, right? Any particular reason I shouldn't do this, other than I'm making work for myself? I'm installing a 2.8.2 agent if it matters, to match my PE server which was installed the sane way.

(The dumb reason is that I have ... (more)

edit retag flag offensive close merge delete

Comments

Please post the last few lines of output from the i386 installer when you run it on your x86_64 machine. My guess is there might be a way to tweak ...(more)

GregLarkin gravatar imageGregLarkin ( 2013-07-16 11:02:14 -0600 )edit

There you go. I suppose I could just comment out the call to platform_support_check? Seems a little scary...

BillWeiss gravatar imageBillWeiss ( 2013-07-16 11:31:11 -0600 )edit

Yes, commenting out platform_support_check would be one way to do it. You could also change the prepare_platform function and replace the "amd64" string with "i386". I'll also add some ...(more)

GregLarkin gravatar imageGregLarkin ( 2013-07-16 12:07:38 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-09-02 08:34:48 -0600

BillWeiss gravatar image

The answer turned out to be, this server is messed up in more ways than this. We burned it down and started over with a VM that know what architecture it was on.

Not the most satisfying answer, but it worked.

edit flag offensive delete link more

Comments

Yes, sometimes that's the best option!

GregLarkin gravatar imageGregLarkin ( 2013-09-02 21:16:12 -0600 )edit
0

answered 2013-07-16 12:09:55 -0600

GregLarkin gravatar image

With some changes to the installer script, Puppet Labs could support your configuration. Please check the Unsupported Platforms issue they have in their bug tracker and add your specific configuration. Perhaps they will update the installer script to support Ubuntu multi-arch natively.

edit flag offensive delete link more

Comments

I don't know if this is really a platform to be supported, since I'm pretty sure it's a sad server :) However, I'll take a look.

BillWeiss gravatar imageBillWeiss ( 2013-07-16 12:57:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-12 23:19:10 -0600

Seen: 254 times

Last updated: Sep 02 '13