Ask Your Question
0

how to solve master and agent connection ?

asked 2013-07-16 03:56:04 -0500

kenju254 gravatar image

updated 2013-07-16 16:44:52 -0500

ramindk gravatar image

Hi

I am trying to connect my agent to master and I am getting this error.

# puppet agent
notice: Starting Puppet client version 2.7.18
err: Could not retrieve catalog from remote server: Server hostname 'ec2-54-213-51-26.us-west-2.compute.amazonaws.com' did not match server certificate; expected one of <a href="http://puppet.ec2-50-112-190-206.us-west-2.compute.amazonaws.com">puppet.ec2-50-112-190-206.us-west-2.compute.amazonaws.com</a>, DNS:ip-172-31-7-119.us-west-2.compute.internal, DNS:puppet, <a href="http://DNS:puppet.ec2-50-112-190-206.us-west-2.compute.amazonaws.com">DNS:puppet.ec2-50-112-190-206.us-west-2.compute.amazonaws.com</a>, DNS:puppet.us-west-2.compute.internal
notice: Using cached catalog
err ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-07-16 13:58:01 -0500

GregLarkin gravatar image

Please follow the steps in the troubleshooting guide regarding "hostname doesn't match errors" and make sure the hostname "ec2-54-213-51-26.us-west-2.compute.amazonaws.com" is included in the server certificate.

edit flag offensive delete link more

Comments

Thanks this solved my issues. My problem was the hostname

kenju254 gravatar imagekenju254 ( 2013-09-02 05:37:03 -0500 )edit

Glad it helped, and please mark my answer as correct when you have moment - thank you!

GregLarkin gravatar imageGregLarkin ( 2013-09-02 19:17:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-16 03:56:04 -0500

Seen: 6,052 times

Last updated: Jul 16 '13