Ask Your Question
0

No [Master] in my puppet.conf file. I can only see [main] and [agent] by default

asked 2015-11-05 15:27:56 -0500

sandeep gravatar image

No [Master] in my puppet.conf file. I can only see [main] and [agent] by default after installation. my installation is open source puppet master. So my question is should i create entry [Master] manually in my puppet.conf file to enable settings? or can i put all the settings (entries) in [Main] ???

Can someone please clarify?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-11-06 09:31:10 -0500

far4d gravatar image

It should be possible to put the settings in [Main]. See here: Config Files: The Main Config File (puppet.conf).

But as noted in the link, master-specific settings should be under [Master].

HTH

edit flag offensive delete link more

Comments

Thanks for your response. So can i manually create an entry for [master] in puppet.conf file? because i have only [main] and [agent] by default.

sandeep gravatar imagesandeep ( 2015-11-06 10:35:21 -0500 )edit

yes. that's fine

far4d gravatar imagefar4d ( 2015-11-07 15:05:06 -0500 )edit

Remember, you can set values using the puppet config command. Here's an example setting the 'server' value in the 'agent' section of the puppet.conf puppet config set server=1.2.3.4 --section agent

DarylW gravatar imageDarylW ( 2015-11-13 08:42:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-05 15:27:56 -0500

Seen: 104 times

Last updated: Nov 06 '15