Ask Your Question
0

Puppet 4 Instllation

asked 2015-11-10 13:14:41 -0500

venkataramana gravatar image

Hi All, I have used community edition puppet 3.1.1 versions before and want to try puppet 4. I am quite confused with puppet 4 installations. Are the packages listed in the below URL/repo what constitute puppet 4?

https://yum.puppetlabs.com/el/6.5/PC1...

They are versioned differently 1.x,2.x etc but no packages with versions 4.x in them.

Please help me understand.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-11-11 09:39:14 -0500

the components of puppet version numbers do not correspond to the puppet release number. e.g. puppet 4. uses mco 2.0, facter 2.4.0 cfacter 0.4 similarly different versions for puppetdb etc etc

you do have the correct repo - dont try and install the rpms on an individual basis - using pc1 is fine

edit flag offensive delete link more

Comments

Thank you.

venkataramana gravatar imagevenkataramana ( 2015-11-11 10:22:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-10 13:12:20 -0500

Seen: 224 times

Last updated: Nov 11 '15