Ask Your Question
0

how to change proxy in windows

asked 2015-11-20 04:12:13 -0500

puppet gravatar image

I am trying to install puppet stdlib module in windows using

"puppet module install puppetlabs-stdlib" command

but I am getting following error message

Error: Could not connect to https://forgeapi.puppetlabs.com There was a network communications problem The error we caught said 'A connection attempt failed because the connected party did not properly respond after a period of time,or established connection failed because connected host has failed to respond. - connect(2) for "forgeapi.puppetlabs.com" port 443' Check your network connection and try again


I didn't understand how to change proxy setting to overcome with this. If anybody know please tell me in detail Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-12-02 15:29:57 -0500

Hi, This looks like a network problem communicating with the server. Can you confirm if you can successfully ping the server? Just open a command prompt and execute the ping command 'ping forgeapi.puppetlabs.com'. If successful you should see replies like below...

ping forgeapi.puppetlabs.com PING forge-api-fr.puppetlabs.com (23.236.57.230): 56 data bytes 64 bytes from 23.236.57.230: icmpseq=0 ttl=45 time=122.380 ms 64 bytes from 23.236.57.230: icmpseq=1 ttl=45 time=122.543 ms 64 bytes from 23.236.57.230: icmpseq=2 ttl=45 time=121.947 ms 64 bytes from 23.236.57.230: icmpseq=3 ttl=45 time=123.244 ms

edit flag offensive delete link more
0

answered 2016-05-10 05:56:48 -0500

suman gravatar image

I am also facing the same issue while installing any module from powershell. Did anyone found a resolution to this problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-20 04:12:13 -0500

Seen: 270 times

Last updated: May 10 '16