Ask Your Question

failure to parse node manifest

asked 2013-07-17 20:09:22 -0600

BaltoStar gravatar image

puppet master + agent v2.7.22 co-located on Unbuntu 12.04 LTS



<a href=""></a>
<a href=""></a>

agent cert has been created and accepted on master

$ sudo puppet agent --test

err: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not parse for environment production: Syntax error at '.' at /etc/puppet/manifests/site.pp:1 on node <a ...
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2013-07-18 08:32:06 -0600

Ancillas gravatar image

Try wrapping your node definition in quotes.

node '' {
  include blah
edit flag offensive delete link more


Thanks Ancillas that did the trick.

BaltoStar gravatar imageBaltoStar ( 2013-07-18 12:45:56 -0600 )edit

answered 2015-01-06 10:24:34 -0600

max gravatar image

I got the same error on my setup. My issue was that I didn't have a closing "}" at the end of my node declaration. It happened when I merged code from my dev file to my prod version and I didn't catch it. Adding quotes in the node definition didn't solve my problem. Hope this helps someone out there.

edit flag offensive delete link more

answered 2015-01-07 14:53:44 -0600

rnelson0 gravatar image

Try running puppet parser validate site.pp. If there are syntax issues as max suggested, you should receive feedback. If you receive no output from the command, then the parser did not encounter known syntax issues and you can probably look elsewhere.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-07-17 20:09:22 -0600

Seen: 2,273 times

Last updated: Jan 07 '15