Ask Your Question
0

f5 certs issue

asked 2013-07-18 14:07:50 -0500

BaltoStar gravatar image

puppet (v2.7.22) master + agent on single server (Ubuntu 12.04.2 LTS) with agent serving as f5_proxy

I have defined no partitions other than default Common partition. Account admin is full administrator on f5 device.

Following the instructions at http://forge.puppetlabs.com/puppetlabs/f5 :

node.pp

node f5_proxy {
  include f5

  f5::config { "f5.test.mydomain.com":
    username => 'admin',
    password => 'admin',
    url      => 'f5.test.mydomain.com',
    target   => '/etc/puppet/device/f5.test.mydomain.com.conf'
  }
}

f5.test.mydomain.com.conf

[f5.test.mydomain.com]
type f5
url `https://admin:admin@f5.test.mydomain.com/`

Running puppet device --deviceconf ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-07-18 17:40:10 -0500

Have you signed the certificate? On your puppet master, run 'puppet cert list'. You will likely see a certificate waiting to be signed named 'f5.test.mydomain.com'. To sign it run 'puppet cert sign f5.test.mydomain.com'

edit flag offensive delete link more

Comments

Thanks Adam. Actually I knew about master needing to sign new agent certs .. but I assumed this was issue with cert on f5 device itself ( as opposed to puppet agent ...(more)

BaltoStar gravatar imageBaltoStar ( 2013-07-18 18:01:07 -0500 )edit

The cert on the f5 doesn't matter for this module, so the default localhost.localdomain shouldn't have any impact.

Adam Crews gravatar imageAdam Crews ( 2013-07-18 20:56:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-07-18 14:07:50 -0500

Seen: 105 times

Last updated: Jul 18 '13