Ask Your Question

f5 certs issue

asked 2013-07-18 14:07:50 -0600

BaltoStar gravatar image

puppet (v2.7.22) master + agent on single server (Ubuntu 12.04.2 LTS) with agent serving as f5_proxy

I have defined no partitions other than default Common partition. Account admin is full administrator on f5 device.

Following the instructions at :


node f5_proxy {
  include f5

  f5::config { "":
    username => 'admin',
    password => 'admin',
    url      => '',
    target   => '/etc/puppet/device/'

type f5
url ``

Running puppet device --deviceconf ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-07-18 17:40:10 -0600

Have you signed the certificate? On your puppet master, run 'puppet cert list'. You will likely see a certificate waiting to be signed named ''. To sign it run 'puppet cert sign'

edit flag offensive delete link more


Thanks Adam. Actually I knew about master needing to sign new agent certs .. but I assumed this was issue with cert on f5 device itself ( as opposed to puppet agent ...(more)

BaltoStar gravatar imageBaltoStar ( 2013-07-18 18:01:07 -0600 )edit

The cert on the f5 doesn't matter for this module, so the default localhost.localdomain shouldn't have any impact.

Adam Crews gravatar imageAdam Crews ( 2013-07-18 20:56:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2013-07-18 14:07:50 -0600

Seen: 112 times

Last updated: Jul 18 '13