Centos 6 Repo Installing EL7 Puppet

asked 2015-12-06 15:19:11 -0600

RetroSpock gravatar image

Hey, I have installed the CentOS6 repo (puppetlabs-release-el-6.noarch.rpm) and I attempt to do a yum install puppet... However, I get:

Error: Package: puppet-3.8.4-1.el7.noarch (puppetlabs-products) Requires: systemd Error: Package: hiera-1.3.4-1.el7.noarch (puppetlabs-products) Requires: rubygem-json Error: Package: 1:ruby-shadow-2.2.0-2.el7.x8664 (puppetlabs-deps) Requires: libruby.so.2.0()(64bit) Error: Package: ruby-augeas-0.4.1-3.el7.x8664 (puppetlabs-deps) Requires: libruby.so.2.0()(64bit) Error: Package: puppet-3.8.4-1.el7.noarch (puppetlabs-products) Requires: rubygem-json Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps) Requires: ruby(release) = 2.0.0

It's trying to install the EL7 package.

I've tried "yum clean all" and I've tried "rpm --rebuilddb yum update" but the problem still persists.

Any ideas why?

Thanks

Edit: I have resolved this by running the clean commands again. Thanks

edit retag flag offensive close merge delete