Ask Your Question
0

Razor can't load miniroot: "result too large"

asked 2015-12-08 15:22:13 -0500

wsanders1 gravatar image

updated 2015-12-08 16:30:28 -0500

Trying to get razor to work. DHCP/tftpboot working, I get the bootstrap.ipxe downloaded OK, but the URL used to try to get the miniroot is malformed:

screen shot

Any ideas why this would happen? This is the tftpd that comes with the dnsmasq 2.48-14.el6 rpm in centos 6.7. Is it too old to support largeish TFTP downloads?

Also, razor is not logging anything to /var/log/puppetlabs/razor-server/server.log except for jboss messages from razor-server-knob.yml. How can I get razor to log ipxe download attempts?

Razor Server version: 1.0.1.2 Razor Client version: 1.0.0

[UPDATE - This appears to be an attempt to download via http on the https port....] [UPDATE - No, because ipxe doesn't support https..]

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-12-09 15:39:01 -0500

GregLarkin gravatar image

This reference (https://github.com/puppetlabs/razor-server/wiki/Common-problems-and-solutions#could-not-boot-image-result-too-large) suggests trying to visit the URL displayed by the Razor boot process in a browser to see if there's an invalid response from the web server.

Ideally, if there's an error displayed in the browser, you'll also want to see what the server logged, but you noted that you don't see much there.

I don't know if this is related, but perhaps there is some information here about how to tweak the logging to get what you want? https://github.com/puppetlabs/razor-server/blob/master/doc/logging.md#logging

edit flag offensive delete link more
0

answered 2015-12-09 16:01:13 -0500

wsanders1 gravatar image

Thanks. I finally got the microkernel to boot, but via HTTP (port 8150) not HTTPS. My bad for not paying close attention to the HTTP return code when I snooped the transaction with tcpdump. A couple of observations:

  • The documentation at https://docs.puppetlabs.com/pe/latest... says to use the HTTPS port, so the doc is wrong
  • iPXE can't do HTTPS requests anyway
  • I have no cert for the razor server, I couldn't generate a self signed one that the razor server would start up with, and puppet overwrite it anyway with the one in it's repo, so I went back to using the one puppet supplied. Red herring.
  • I swear I tried port 8150 yesterday and it didn't work. But I didn't try testing it with curl.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-08 15:21:38 -0500

Seen: 192 times

Last updated: Dec 09 '15