Ask Your Question
0

updating package and all dependency updates with puppet

asked 2013-07-23 08:22:40 -0500

cko gravatar image

hi, im trying to update the zend server package the following way:

  package { "zend-server-php-5.4-6.1.0:
    ensure => present,
    require => [Yumrepo["ZendRepo"],Yumrepo["Zend_noarch"]],
    notify => File["/etc/ld.so.conf.d/zend_server.conf"]
  }

when i install a node from scratch, the latest version (including the latest depencencies) gets installed.

when i apply this to an existing node (with an older version of zend server) ONLY the package ""zend-server-php-" gets updated. updates for the packages "mod-php-5.4-apache2-zend-server-" and " php-5.4.16" (the dependencies) are ignored.

whats the best way to solve this?

i was thinking about an "yum update php*" exec?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-07-23 11:07:09 -0500

GregLarkin gravatar image

There is an open feature request to support integration with package manager dependencies, but as you can see by reading it, there's no target release yet.

In the mean time, I would go the route that you suggested, but I would list the dependencies explicitly instead of globbing them with php*. That way, you know exactly what's happening and shouldn't get any unintended updates lumped in.

I'm not a yum expert, but I believe you can find the list of dependencies from your Zend Server package with the command (if it's already installed somewhere):

yum ...
(more)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-23 08:22:40 -0500

Seen: 185 times

Last updated: Jul 23 '13