Ask Your Question
0

Could not retrieve catalog from remote server

asked 2015-12-16 03:12:45 -0500

Kartik gravatar image

Hi All, I'm new to puppet (been a week) and got stuck with an issue. Managed to setup a master and couple of nodes which are running fine.

Tried the below module sample: https://www.linode.com/docs/applicati...

but when i tried to run

puppet agent -t --debug

I get the below error message:

Debug: Using cached connection for https://master:8140
Debug: Caching connection for https://master:8140

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Node <Node1> is already defined; cannot redefine on node <Node1>
edit retag flag offensive close merge delete

Comments

Permissions have been checked. pe-puppet owns the directories

Kartik gravatar imageKartik ( 2015-12-16 03:17:23 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-12-16 18:39:24 -0500

updated 2015-12-29 09:39:40 -0500

The error message is saying that you tried to declare multiple nodes for Node1. Can we see your site.pp file?

UPDATE

I don't know what you're trying to do or what is in your site.pp file so you need to update your post with more information. Thanks.

UPDATE 2

Based on that site.pp file, for your purpose you should be able to add a block:

node 'node1' {
  include accounts
}

If that's what you already tried, I am also confused. Firstly, are you sure?

UPDATE 3

I just tested and it doesn't matter whether you put the default node before or after the other nodes, although most examples place it before.

edit flag offensive delete link more

Comments

Currently my puppet configuration is 1 Master - 4 Nodes I would like to apply a module called "accounts" on node1 alone. How to do that?

Kartik gravatar imageKartik ( 2015-12-21 04:08:13 -0500 )edit

site.pp has been re-added. Please have a look.

Kartik gravatar imageKartik ( 2015-12-21 04:15:30 -0500 )edit

Yes, i've pasted the same below.

Kartik gravatar imageKartik ( 2015-12-21 23:45:05 -0500 )edit

Ok, give me a bit of time, I'll have to try to reproduce this.

Alex Harvey gravatar imageAlex Harvey ( 2015-12-22 21:19:38 -0500 )edit
0

answered 2015-12-21 03:43:04 -0500

Kartik gravatar image

updated 2015-12-29 04:51:57 -0500

Figured out the problem.

External nodes should be define below the default node as below:

      ## site.pp ##

    ## Active Configurations ##

        # PRIMARY FILEBUCKET.

        # Define filebucket 'main':
        filebucket { 'main':
          server => 'master.company.com',
          path   => false,
        }

        # Make filebucket 'main' the default backup location for all File resources:
        File { backup => 'main' }

        # DEFAULT NODE
        node default {
          # This is where you can declare classes for all nodes.
          # Example:
          #   class { 'my_class': }
        }

   node 'node1' {
        include accounts
     }
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-16 03:12:45 -0500

Seen: 2,297 times

Last updated: Dec 29 '15