Ask Your Question
1

passenger logging - how to specify?

asked 2013-07-25 07:08:49 -0500

ethrbunny gravatar image

Since installing passenger the server log location in /etc/sysconfig/puppetmaster doesn't seem to be working anymore. When using webrick it was logging to /var/log/puppet/masterhttp.log (despite supposedly defaulting to syslog).

I have tried to set a new value as:

PUPPETMASTER_LOG=/var/log/puppet/master.log

but the system seems to be ignoring it and continuing to log to /var/log/messages.

What step(s) did I miss?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-29 10:10:19 -0500

ethrbunny gravatar image

FWIW: in your VirtualHost section for Passenger add these lines (or similar):

# logging
LogLevel info
ErrorLog /var/log/puppet/error.log
CustomLog /var/log/puppet/access.log combined
edit flag offensive delete link more
1

answered 2013-08-29 13:07:53 -0500

ramindk gravatar image

Chances are the webrick based master was writing to the file directly whereas your Passenger based master is writing to syslog. The messages are probably in /var/log/messages and you need to configure a destination for them.

Depending on your distro/syslog daemon the following should work.

/etc/rsyslog.d/40-puppet.conf

# PUPPETHEADER: This file is owned by Puppet.
# puppet logging

if $programname == 'puppet-agent' then -/var/log/puppet/puppet.log
& ~

if $programname == 'puppet-master' then -/var/log/puppet/puppetmaster.log
& ~

Also the Apache logs will just show the http requests not the logs of the Puppet master application.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-07-25 07:08:49 -0500

Seen: 762 times

Last updated: Aug 29 '13