Ask Your Question
0

Invalid parameter options on Apt_key

asked 2015-12-23 04:49:58 -0500

davideagle gravatar image

updated 2015-12-29 16:28:18 -0500

GregLarkin gravatar image

I get this error on puppet run on Ubuntu 14.04 Puppet Agent 3.8.4 Puppet Master 3.8.4 puppetlabs/apt 2.2.1

Reboot of the puppet master seems to temporarily resolve the issue but re-appears after a few hours

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Invalid parameter options on Apt_key[Add key: B97B0AFCAA1A47F044F244A07FCC7D46ACCC4CF8 from Apt::Source apt.postgresql.org] at /etc/puppet/environments/openstack/modules/apt/manifests/key.pp:84 on node puppetdb-test.siminn.is
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-01 00:08:23 -0500

To limit the scope, can you try running the puppet master from the command line:

# service httpd stop
# puppet master --no-daemonize

Do you still see the issue return after a few hours?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-12-23 04:49:58 -0500

Seen: 723 times

Last updated: Jan 01 '16