Ask Your Question
0

How to profile a puppet agent run using passenger.

asked 2016-01-04 07:55:17 -0500

mdelaney gravatar image

updated 2016-01-06 13:48:59 -0500

I'm trying to run Puppet profiler during a catalog run, but I can't seem to get this to work when using mod_passenger. I have set 'debug' to true and 'profile' to true in the Puppet config (/etc/puppet/puppet.conf) file, and restarted Apache after the change. Yet, when I run my puppet agent run, I do not see the profile tags in the log as I would expect.

If I go to the master, and print the 'profile' variable, it returns true so I suspect the '--debug' flag isn't getting set correctly by Passenger(??).

[vagrant@puppet ~]$ sudo puppet config print --section master profile
true

Even though, I have the settings correct (I think), it's not working as I expected it to. Has anyone been able to run the profiler when using passenger?

[EDIT]

If I start the puppet master (sudo puppet master --debug --no-daemonize), I just can't get the PROFILE messages when in passenger. The page Tune Puppet for Performance with Profiler didn't seem to help much in this scenario.

[UPDATE]

After playing around with config.ru, I found that if I add ARGV << "--logdest" << "console" the profile log gets sent to the Apache error log (/var/log/httpd/error_log). I suspect that systemd/journald (from CentOS) is hiding the messages from the profile. This also doesn't answer why setting 'logdest' to a file(ARGV << "--logdest" << "/tmp/puppet.run.log") doesn't work either.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-05 06:56:09 -0500

Hi,

believe this is the documentation - take a look at:

puppet profiler with passenger

Cheers Stuart

edit flag offensive delete link more

Comments

Thanks Stuart. I tried that and to no avail.

mdelaney gravatar imagemdelaney ( 2016-01-05 07:25:44 -0500 )edit

did you restatr puppet - also what changes did you make to config.ru? cheers Stuart

sahumphries gravatar imagesahumphries ( 2016-01-06 08:18:42 -0500 )edit

Indeed, I did.

mdelaney gravatar imagemdelaney ( 2016-01-06 11:03:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-04 07:55:17 -0500

Seen: 162 times

Last updated: Jan 06 '16