Ask Your Question
0

How to stop puppet agent automatic run that happens every 30 mins

asked 2016-01-07 15:44:29 -0500

sandeep gravatar image

updated 2016-01-07 15:55:34 -0500

I want to stop puppet agent running automatically every 30 mins..i want to run only manually all the time i.e by giving puppet agent -t command. So what to do to stop agent automatic run?

i tried giving below entry in agent puppet.conf but it didn't work.

[agent] daemonize=false

Can someone help?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-01-08 05:15:00 -0500

updated 2016-01-08 05:15:59 -0500

Maybe

puppet agent --disable "Reason why disabled"

will help you. Otherwise you can try:

service puppet stop; chkconfig puppet off

Hope that helps!

edit flag offensive delete link more
0

answered 2016-01-08 04:12:24 -0500

YevgenyT gravatar image

What OS you use? In the common Linux flavors you have /etc/default/puppet that will control if the Puppet agent daemon starts automatically.

edit flag offensive delete link more
0

answered 2016-01-08 11:22:37 -0500

swarly gravatar image

In my case, I wanted to leave the agent running, but not have it check in every 30 mins, so I just set the check-in interval to a really large # (e.g. 32,000,000 secs =~ 1 year), which effectively disables it, unless you only perform updates via Puppet less than 1x/year!

e.g.:

[agent]
  runinterval = 32900900
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-07 15:44:29 -0500

Seen: 275 times

Last updated: Jan 08 '16