Ask Your Question
1

gem ignores --source

asked 2013-07-31 11:51:18 -0500

updated 2013-07-31 12:19:17 -0500

Stefan gravatar image

this is Puppet Enterprise 3 . . .

I have an environment with no external internet access. I've setup a ruby gem repo in that environment so that I can install gems used by my facter code. When the manifest runs it seems to ignore the --source argument. The command is clearly printed with my --source http://mygemserver:6789 but it tries to use rubygems.org 4 times and then fails.

I also tried adding /etc/gemrc with only my internal source and that didnt help.

If I run /opt/puppet/bin/gem install manually as root then it works, but it ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-07-31 12:32:01 -0500

Stefan gravatar image

This seems to be bug 18053. Do you have a $HOME/.gemrc file and if so can you print the content?

The HOME variable is unset when running puppet (due to issue 5224) and that is the only thing that should be different compared to running the gem command on the commandline.

edit flag offensive delete link more

Comments

I do have a ~/.gemrc however the system also has a /etc/gemrc that does not rely on the $HOME env var

Ghost Rider gravatar imageGhost Rider ( 2013-07-31 12:51:04 -0500 )edit

cat /etc/gemrc --- :sources: - http://rubygems:6789/ :benchmark: false :backtrace: false :verbose: true :bulk_threshold: 1000 :update_sources: true

Ghost Rider gravatar imageGhost Rider ( 2013-07-31 12:58:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-31 11:51:18 -0500

Seen: 349 times

Last updated: Jul 31 '13