Ask Your Question
0

Unable to get PuppetDB to work. SSL hostname mismatch

asked 2016-01-08 15:32:09 -0500

Tozz gravatar image

I am trying to configure PuppetDB but have an issue I cant seem to resolve. I followed:

Install manual

PuppetDB is running, but I get this error in puppetmaster.log:

2016-01-08 22:22:29,414 WARN  [qtp1989499399-63] [puppet-server] Puppet Specification of server and port in puppetdb.conf is deprecated. Use the setting server_urls.
2016-01-08 22:22:30,149 ERROR [qtp1989499399-63] [c.p.h.c.i.PersistentSyncHttpClient] Error executing http request javax.net.ssl.SSLException: hostname in certificate didn't match: <puppetdb> != <puppet.X.net> OR <puppet.X.nl> OR <puppet.X.net> OR <puppet.X.net>

I am not entirely sure if this means that PuppetDB on 8081 has "puppetdb" as CN or that Puppet is looking for "puppetdb" as CN, but finds other names. it is unclear to me why i get "puppetdb" as hostname in the firstname. Because my puppetdb.conf is as following:

/etc/puppetlabs/puppetdb/puppetdb.conf:

[main]
server_urls = https://puppet.X.net:8081

Again, i entered the correct hostname here (puppet instead of puppetdb). And I am also using "serverurls" which makes me wonder why I get the warning "specification of server and port in pupetdb.conf is deprecated. use the setting serverurls.

My issue is exactly the same as discussed here (but without a solution):

Google Groups

And again here:

Github

I hope someone can help me resolve this issue.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-08 15:53:45 -0500

Tozz gravatar image

updated 2016-03-14 05:40:10 -0500

Ofcourse, after searching and Googlling for hours, you find the solution within a few minutes after posting the question.

I managed to resolve this issue by symlinking /etc/puppetlabs/puppetdb/puppetdb.conf to /etc/puppetlabs/puppet/puppetdb.conf.

In short: I placed puppetdb.conf in the wrong location.

Note: This problem surfaced again after some time, it turned out Puppetserver (running as user Puppet) dit not have permissions to read puppetdb.conf. So you might want to check this as well!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-08 15:32:09 -0500

Seen: 263 times

Last updated: Mar 14 '16