Ask Your Question

Any advice to check out the PuppetDB health?

asked 2013-08-01 15:53:25 -0600

jaisol gravatar image


I went through already.

PuppetDB 1.3.2 is not resolving simple curl queries such as: curl -H "Accept: application/json" http://puppetdb-server:8082/facts/server-name

I'm able to see the puppetdb dashboard @ http://puppetdb-server:8082/dashboard/index.html and I also reviewed the log @ /var/log/puppetdb/puppetdb.log but i don't find anything strange in there.

I restarted both the puppetdb and puppetmaster services and still no having luck with the puppetdb curl queries. Both services have been up and running with no issues ... (more)

edit retag flag offensive close merge delete


So normally puppetdb runs on port 8080 cleartext, and port 8081. You can find that out in your /etc/puppetdb/conf.d/jetty.ini file. Your query is for an ...(more)

ken gravatar imageken ( 2013-08-01 16:25:14 -0600 )edit

I already changed the port to 8082 (port=8082) on the jetty.ini file so puppetdb is responding to 8082 port, that's why puppetdb dashboard can be accessed @ http ...(more)

jaisol gravatar imagejaisol ( 2013-08-01 16:39:29 -0600 )edit

What happens with the curl? If you do curl -vvv on those end-points - can you show me the result in a gist or something?

ken gravatar imageken ( 2013-08-01 16:56:14 -0600 )edit

I haven't used curl -vvv yet. :-( What would be the syntaxis? Thanks!

jaisol gravatar imagejaisol ( 2013-08-01 17:11:48 -0600 )edit

I ran it as is and here is the results: # curl -vvv http://puppetdb-server:8082/nodes * About to connect() to puppet-server port 8082 (#0) * Trying Connection ...(more)

jaisol gravatar imagejaisol ( 2013-08-01 17:14:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-02-20 19:17:15 -0600

James gravatar image

This is pretty old question. However let me answer it.

If you are accessing puppetdb from another host, there are few guidelines. From your question, I see that you are using PuppetDB 1.3. Please refer this page.

There are two important points you are missing. A. You should use a valid SSL cert and a CA. B. The cert name should be added to the whitelist in your puppetdb configuration.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2013-08-01 15:53:25 -0600

Seen: 582 times

Last updated: Feb 20 '14