Ask Your Question
0

Why does puppet module list complain about missing dependencies?

asked 2016-01-20 09:20:11 -0500

kasimon gravatar image

What causes these puppetlabs-stdlib dependency errors?

# puppet --version
3.8.4
# puppet module list --tree --verbose
Warning: Missing dependency 'puppetlabs-stdlib':
  'hunner-hiera' (v1.4.1) requires 'puppetlabs-stdlib' (>= 4.3.1 < 5.0.0)
/etc/puppet/environments/production/modules
├── torrancew-account (v0.0.5)
├─┬ puppetlabs-apt (v2.2.1)
│ └── puppetlabs-stdlib (v4.11.0)
├─┬ hunner-hiera (v1.4.1)
│ └── UNMET DEPENDENCY puppetlabs-stdlib (>= 4.3.1 < 5.0.0)
├── profiles (???)
└── roles (???)
/etc/puppet/modules (no modules installed)
/usr/share/puppet/modules (no modules installed)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-01-21 03:20:09 -0500

fvoges gravatar image

Because

Warning: Missing dependency 'puppetlabs-stdlib':
  'hunner-hiera' (v1.4.1) requires 'puppetlabs-stdlib' (>= 4.3.1 < 5.0.0)

hunner-hiera requires puppetlabs-stdlib with a version greather/equal to 4.3.1 but less than 5

But you currently have installed puppetlabs-stdlib version 4.11.0

├─┬ puppetlabs-apt (v2.2.1)
│ └── puppetlabs-stdlib (v4.11.0)

You'll have to update your puppetlabs-stdlib version (puppet module upgrade puppetlabs-stdlib)

edit flag offensive delete link more

Comments

Is there something wrong? 5.0.0 > 4.11(eleven).0 >= 4.3(three).1 right? Why should have to update?

DevOPs_Paul.Tung gravatar imageDevOPs_Paul.Tung ( 2016-07-20 03:25:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-01-20 09:20:11 -0500

Seen: 698 times

Last updated: Jan 21 '16