Only mco ping works, no errors in logs on agent or puppet master

asked 2016-01-24 07:22:33 -0600

kartik_puppet_labs gravatar image
[root@puppet ~]# cat /etc/mcollective/server.cfg

maincollective = mcollective connector = activemq directaddressing = 1 collectives = mcollective libdir = /usr/local/libexec/mcollective:/usr/libexec/mcollective

logger_type = console

loglevel = warn

logfile = /var/log/mcollective.log loglevel = info

Plugins

securityprovider = psk plugin.psk = 111222333qqqeeefffggghhhiii

connector = activemq plugin.activemq.pool.size = 1 plugin.activemq.pool.1.host = puppet.kartikv.com plugin.activemq.pool.1.port = 61613 plugin.activemq.pool.1.user = system plugin.activemq.pool.1.password = manager

Facts

factsource = yaml plugin.yaml = /etc/mcollective/facts.yaml

Send heartbeats in 30 second intervals. This is the shortest supported period.

plugin.activemq.heartbeat_interval = 30

By default if heartbeat_interval is set it will request STOMP 1.1 but support fallback

to 1.0, but you can enable strict STOMP 1.1 only operation by disabling 1.0 fallback

plugin.activemq.stomp10_fallback = 0

Maximum amount of heartbeat read failures before retrying. 0 means never retry.

plugin.activemq.maxhbreadfails = 2

Maximum amount of heartbeat lock obtain failures before retrying. 0 means never retry.

plugin.activemq.maxhbrlckfails = 0 [root@puppet ~]# ps -ef | grep -i mco root 12480 1 0 07:56 ? 00:00:00 /usr/bin/ruby /usr/sbin/mcollectived --config=/etc/mcollective/server.cfg --pidfile=/var/run/mcollective.pid --no-daemonize root 13582 12283 0 08:11 pts/2 00:00:00 grep --color=auto -i mco [root@puppet ~]#

[root@puppet ~]# tail -f /var/log/mcollective.log

I, [2016-01-24T07:53:33.132700 #12389] INFO -- : activemq.rb:211:in initialize' ActiveMQ connector initialized. Using stomp-gem 1.3.4 I, [2016-01-24T07:53:33.133494 #12389] INFO -- : activemq.rb:313:inconnectionheaders' Connecting without STOMP 1.1 heartbeats, if you are using ActiveMQ 5.8 or newer consider setting plugin.activemq.heartbeatinterval I, [2016-01-24T07:53:33.134043 #12389] INFO -- : activemq.rb:114:in on_connecting' TCP Connection attempt 0 to stomp://system@puppet.kartikv.com:61613 I, [2016-01-24T07:53:33.149636 #12389] INFO -- : activemq.rb:119:inonconnected' Connected to stomp://system@puppet.kartikv.com:61613 I, [2016-01-24T07:56:22.009320 #12389] INFO -- : runner.rb:104:in rescue in block in main_loop' Exiting after signal: SIGTERM I, [2016-01-24T07:56:22.353154 #12480] INFO -- : config.rb:167:inloadconfig' The Marionette Collective version 2.8.4 started by /usr/sbin/mcollectived using config file /etc/mcollective/server.cfg I, [2016-01-24T07:56:22.353322 #12480] INFO -- : mcollectived:64:in <main>' The Marionette Collective 2.8.4 started logging at info level I, [2016-01-24T07:56:22.353543 #12480] INFO -- : activemq.rb:211:ininitialize' ActiveMQ connector initialized. Using stomp-gem 1.3.4 I, [2016-01-24T07:56:22.354653 #12480] INFO -- : activemq.rb:114:in on_connecting' TCP Connection attempt 0 to stomp://system@puppet.kartikv.com:61613 I, [2016-01-24T07:56:22.369879 #12480] INFO -- : activemq.rb:119:inonconnected' Connected to stomp://system@puppet.kartikv.com:61613

On agent:

[root@test11 ~]# tail -f /var/log/mcollective.log

I, [2016-01-18T00:48:49.494589 #22090] INFO -- : activemq.rb:211:in initialize' ActiveMQ connector initialized. Using stomp-gem 1.3.4 ... (more)

edit retag flag offensive close merge delete