Ask Your Question
0

Puppetboard cannot connect to puppetdb

asked 2016-02-01 12:12:11 -0500

Tried recommended test of wsgi module and cannot connect to puppetd. This is RHEL 6 running wsgi on apache. The puppetdb website is available at http://<hostname>:8080.

[root@lccns865 puppetboard]# python /var/www/puppetboard/wsgi.py

INFO:requests.packages.urllib3.connectionpool:Starting new HTTP connection (1): localhost ERROR:pypuppetdb.api:Could not reach PuppetDB on localhost:8080 over HTTP. Traceback (most recent call last): File "/var/www/puppetboard/wsgi.py", line 6, in <module> from puppetboard.app import app as application File "/usr/lib/python2.6/site-packages/puppetboard/app.py", line 88, in <module> envs = environments() File "/usr/lib/python2.6/site-packages/puppetboard/app.py", line 73, in environments envs = getorabort(puppetdb.environments) File "/usr/lib/python2.6/site-packages/puppetboard/utils.py", line 28, in getorabort abort(500) File "/usr/lib/python2.6/site-packages/werkzeug/exceptions.py", line 646, in call raise self.mappingcode werkzeug.exceptions.InternalServerError: 500: Internal Server Error

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-05 08:26:04 -0500

jon6000 gravatar image

Hi,

Is PuppetDB listening on the local interface? If not you may need to change jetty.ini to listen on all interfaces.

Jon

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-01 12:12:11 -0500

Seen: 256 times

Last updated: Feb 05 '16