Ask Your Question

PuppetDB won't bind SSL port on Ubuntu

asked 2013-08-07 10:56:01 -0600

ryanbrooks gravatar image

updated 2013-08-08 03:32:05 -0600

I am using the PuppetLabs APT repository and have installed puppetdb and puppetmaster from there.

Puppetdb starts fine when the SSL options are commented out (for example just opening an unencrypted port on 8080). If the SSL option is added in I get the following error in puppetdb.log:

2013-08-07 15:46:00,483 WARN  [clojure-agent-send-off-pool-2] [component.AbstractLifeCycle] FAILED SslSelectChannelConnector@REDACTED:8081: Cannot assign requested address Cannot assign requested address
        at Method)
        at ...
edit retag flag offensive close merge delete


Is the output of the command "netstat -an | grep 8081" empty?

GregLarkin gravatar imageGregLarkin ( 2013-08-07 13:00:42 -0600 )edit

Could also be trying to bind to an IP address not available on your box, try ssl-host= instead. Greg's suggestion is also worth checking as ...(more)

ken gravatar imageken ( 2013-08-07 13:23:21 -0600 )edit

Thanks for both comments. I should have said that nothing else was bound to the port (in fact a variety of other ports also failed). Ken's suggestion resolved my ...(more)

ryanbrooks gravatar imageryanbrooks ( 2013-08-08 03:05:42 -0600 )edit

I've added an answer as requested Ryan, for completeness.

ken gravatar imageken ( 2013-08-14 08:45:43 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-08-14 08:44:53 -0600

updated 2013-08-14 08:46:39 -0600

PuppetDB could be trying to bind to an IP address not available on your box, in your jetty.ini file try:


... instead of using a hostname, as it might be resolving to an IP address the box doesn't know about.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-08-07 10:56:01 -0600

Seen: 776 times

Last updated: Aug 14 '13