Ask Your Question
0

Find version of puppet master required for installing puppet module

asked 2016-02-03 07:55:16 -0500

link0876 gravatar image

I will implement Bareos backup solution. I want to use puppet to install agents to all servers and then keep those agents updated.

I found 2 modules on forge.puppetlabs.com

https://forge.puppetlabs.com/thbe/bareos

https://forge.puppetlabs.com/netmanag...

How to determine the lowest version of puppet master for these modules?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-03 09:02:54 -0500

Raise an issue at their projects, asking the authors to update the documentation to be clear about which versions of Puppet are supported. Failing that, you just have to try it. It's likely to be as simple as finding out: is Puppet 4 supported or not? If not, probably use Puppet 3.8.5. If it is, probably use latest Puppet 4.

edit flag offensive delete link more

Comments

To this I only want to add that as Sys Admin I am responsible for keeping almost all software up to date, because old software become security vulnerable. Because of this keeping puppet muster not updated is not recommended.

link0876 gravatar imagelink0876 ( 2016-02-05 03:08:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-03 07:55:16 -0500

Seen: 74 times

Last updated: Feb 03 '16