Ask Your Question
0

docker: flag provided but not defined: -d (agent node setup quest)

asked 2016-02-07 14:59:55 -0500

ReneCD gravatar image

updated 2016-02-07 17:10:47 -0500

Next question:

Proceeding with the quest I'm now adding

node learning.puppetlabs.vm {
  ...
  include multi_node
}

Then

puppet agent -t

-- Unit docker.service has begun starting up.
Feb 07 20:46:08 learning.puppetlabs.vm docker[13897]: flag provided but not defined: -d
Feb 07 20:46:08 learning.puppetlabs.vm docker[13897]: See '/usr/bin/docker --help'.
Feb 07 20:46:08 learning.puppetlabs.vm systemd[1]: docker.service: main process exited, code=exited, status=125/n/a
Feb 07 20:46:08 learning.puppetlabs.vm systemd[1]: Failed to start Docker Application Container Engine.
-- Subject: Unit docker.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit docker.service has failed.

I know what docker does but otherwise I don't have any experience with it - but it seems to me that since all I do is execute some plugin, the plugin must have a bug?

edit retag flag offensive close merge delete

Comments

1

A recent Docker update changed the flag. There's an open PR for the garethr-module that should resolve this. (https://github.com/garethr/garethr-docker/pull/428)

Kevin gravatar imageKevin ( 2016-02-08 02:24:13 -0500 )edit

Is the "include multi_node" the only thing you include? How does your docker inclusion look like. It looks to me that your docker deamon get's an "-d" in the startup but this flag does not exists. Maybe you also have an incompatible version of docker.

czerwe gravatar imageczerwe ( 2016-02-08 02:55:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-09 09:30:27 -0500

Emma gravatar image

Replace the -d flag with daemon in /etc/puppetlabs/code/modules/docker/run.pp and also /etc/puppetlabs/code/modules/docker/templates/etc/systemd/system/docker.service.d/service-overrides-rhel.conf.erb then run puppet agent -t again. Alternatively waiting for the PR to be merged Kevin mentioned in the above comment should also do it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-07 14:59:55 -0500

Seen: 1,959 times

Last updated: Feb 09 '16