Ask Your Question
0

How do I specify future parser in module requirements?

asked 2016-02-08 13:04:41 -0500

AlexL gravatar image

If I have a module that works with Puppet >4.0, or Puppet >3.8.1 w/ future parser enabled, how do I specify that in the requirements of the metadata.json?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-09 10:56:50 -0500

You can specify the puppet version using something like:

  "requirements": [
    {
      "name": "pe",
      "version_requirement": ">= 3.0.0 < 2015.4.0"
    },
    {
      "name": "puppet",
      "version_requirement": ">= 3.0.0 < 5.0.0"
    }
  ],

I doubt that you can specify specifically "3.8 with future parser" but I don't know this.

edit flag offensive delete link more

Comments

Correct, you cannot specify dependency on "3.x with future parser."

Henrik Lindberg gravatar imageHenrik Lindberg ( 2016-02-15 06:54:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-02-08 13:04:41 -0500

Seen: 161 times

Last updated: Feb 09 '16