Ask Your Question
0

puppet web console is not working.

asked 2016-02-09 21:42:01 -0500

chaitanya gravatar image

updated 2016-02-10 19:13:52 -0500

Hi All,

I am trying to install puppet master and agent in virtualbox. I have setup two servers (Centos) properly and able do ssh from outside (from windows). Both servers is giving proper ip address. I have used "Bridge Adapter".

But still I am not able to access the web console url. I tried with IP address (https://192.168.0.17:3000). When I checked nmap.

The port is service is PPP.

3000/tcp open ppp

I am not sure whether it is causing the issue PPP service. I think it should point to http. Please help me.

I checked httpd service is running, "ps -eaf | grep http" is giving result.

when i check "curl https://puppetmaster:3000" it is giving error but when I give "curl -k https://puppetmaster:3000" it is giving content. It is not working in from chrome or any browser.

thanks, Chaitanya

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-10 19:50:53 -0500

GregLarkin gravatar image

Hi,

Make sure that the iptables service is turned off in your VM with the command service iptables stop. Or you can add a rule to allow connections to port 3000.

You don't need to be concerned that the port 3000 is mapped to the service "ppp". That's just an artifact of the mapping in the /etc/services file. Port 3000 must have an entry in that file, but as long as no other service is using it, the Puppet installer uses it, and there's no problem.

I don't believe you are seeing an httpd process because the graphical installer is a Ruby application and probably has a different type of process name.

If turning off iptables or opening port 3000 doesn't work, please post the relevant error messages as a link to a pastebin.

edit flag offensive delete link more
0

answered 2016-02-12 08:05:11 -0500

chaitanya gravatar image

updated 2016-02-12 08:28:52 -0500

Thanks for reply. I executed the command "service iptables stop" it is giving an error saying "Unit iptables.service failed to load: No such file or director".

I tried different approaches still it didnt work. Finally I removed the iptables then it is working fine but some times when I tried to remove iptables many dependent packages got removed.

I installed "yum install iptables-services" and successfully disabled iptables but still console is showing error if I am not removing iptables.

Some time i am getting this error while installing. Some times it is working fine.

Install Puppet Enterprise on sm.sai.com(host name). [sm.sai.com] An error occured while performing installpesm.sai.com: invalid byte sequence in US-ASCII

Please let me know what needs to be done.

Thanks, Chaitanya

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-09 21:42:01 -0500

Seen: 241 times

Last updated: Feb 12 '16