Restarted the master now not working

asked 2016-02-15 05:10:08 -0600

leeroy gravatar image

My puppet master was working but now giving me this error when running puppet agent -t on the master.

Warning: Unable to fetch my node definition, but the agent run will continue: Warning: getaddrinfo: Name or service not known Info: Retrieving pluginfacts Error: /File[/opt/puppetlabs/puppet/cache/facts.d]: Failed to generate additional resources using 'evalgenerate': getaddrinfo: Name or service not known Error: /File[/opt/puppetlabs/puppet/cache/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet:///pluginfacts: getaddrinfo: Name or service not known Info: Retrieving plugin Error: /File[/opt/puppetlabs/puppet/cache/lib]: Failed to generate additional resources using 'evalgenerate': getaddrinfo: Name or service not known Error: /File[/opt/puppetlabs/puppet/cache/lib]: Could not evaluate: Could not retrieve file metadata for puppet:///plugins: getaddrinfo: Name or service not known Info: Loading facts Error: Could not retrieve catalog from remote server: getaddrinfo: Name or service not known Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run Error: Could not send report: getaddrinfo: Name or service not known

Any advice would be greatly appreciated first time posting for tech advice so if you need more info let me know.

Thanks, Liam

edit retag flag offensive close merge delete

Comments

Did you resolve this issue? I've got the same one.

PaulAtkinson1309 gravatar imagePaulAtkinson1309 ( 2016-03-17 08:47:10 -0600 )edit