ProgramData directory missing and puppet.conf ignored

asked 2016-02-18 15:36:03 -0500

theillien gravatar image

I've just installed the agent on a fresh Windows 2008 R2 VM in AWS. I have installed twice, actually. Once with my account which has administrator permissions and once with the actual Administrator account. Neither time has a directory called ProgramData been created. All of the files end up under C:/ProgramFiles/Puppet Labs/Puppet/... including the puppet.conf file.

Is the ProgramData directory an artifact from a bygone era in Puppet documentation? Am I supposed to create the directory?

This becomes an issue because I'm trying to modify the configuration of the agent. When I installed it I entered the FQDN of the Puppet Master, but now I'm trying to change it while testing some other stuff. If I create a server = entry in C:/ProgramFiles/Puppet Labs/Puppet/puppet/conf/puppet.conf it is ignored. Instead, running the agent uses the Puppet Master entered during installation. Where is that stored if not under C:/ProgramData/... or C:/ProgramFiles/Puppet Labs/Puppet/puppet/conf/puppet.conf? Is it in the registry?

edit retag flag offensive close merge delete

Comments

Not being a Windows admin, I did not know that `C:\ProgramData` is a hidden directory. I have since found it.

theillien gravatar imagetheillien ( 2016-02-19 14:41:29 -0500 )edit